<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width" />
<title>APESHIT | An Extreme Metal Webzine</title>
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="stylesheet" type="text/css" media="all" href="http://www.apeshit.org/wp-content/themes/apeshit/style.css" />
<link rel="pingback" href="http://www.apeshit.org/xmlrpc.php" />
<!--[if lt IE 9]>
<script src="http://www.apeshit.org/wp-content/themes/toolbox/js/html5.js" type="text/javascript"></script>
<![endif]-->

<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="APESHIT &raquo; Feed" href="https://www.apeshit.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="APESHIT &raquo; Comments Feed" href="https://www.apeshit.org/comments/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.apeshit.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.1.1"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(p&&p.fillText)switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css' href='http://www.apeshit.org/wp-includes/css/dist/block-library/style.min.css?ver=6.1.1' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css' href='http://www.apeshit.org/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.17' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css' href='http://www.apeshit.org/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=6.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='classic-theme-styles-css' href='http://www.apeshit.org/wp-includes/css/classic-themes.min.css?ver=1' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='jetpack_css-css' href='http://www.apeshit.org/wp-content/plugins/jetpack/css/jetpack.css?ver=11.5.1' type='text/css' media='all' />
<link rel="https://api.w.org/" href="https://www.apeshit.org/wp-json/" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.apeshit.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.apeshit.org/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 6.1.1" />
	<style>img#wpstats{display:none}</style>
		
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="website" />
<meta property="og:title" content="APESHIT" />
<meta property="og:description" content="An Extreme Metal Webzine" />
<meta property="og:url" content="https://www.apeshit.org/" />
<meta property="og:site_name" content="APESHIT" />
<meta property="og:image" content="https://s0.wp.com/i/blank.jpg" />
<meta property="og:image:alt" content="" />
<meta property="og:locale" content="en_US" />

<!-- End Jetpack Open Graph Tags -->
</head>

<body class="home blog">
<div id="page" class="hfeed">
	<header id="branding" role="banner">
		<hgroup>
			<h1 id="site-title"><a href="https://www.apeshit.org/" title="APESHIT" rel="home">APESHIT</a></h1>
			<h2 id="site-description">An Extreme Metal Webzine</h2>
		</hgroup>

		<nav id="access" role="navigation">
			<h1 class="assistive-text section-heading">Main menu</h1>
			<div class="skip-link screen-reader-text"><a href="#content" title="Skip to content">Skip to content</a></div>

			<div class="menu"><ul>
<li class="current_page_item"><a href="https://www.apeshit.org/">Home</a></li><li class="page_item page-item-3065"><a href="https://www.apeshit.org/news/">News</a></li>
<li class="page_item page-item-3068"><a href="https://www.apeshit.org/reviews/">Reviews</a></li>
<li class="page_item page-item-3070"><a href="https://www.apeshit.org/features/">Features</a></li>
<li class="page_item page-item-3349"><a href="https://www.apeshit.org/live/">Live</a></li>
<li class="page_item page-item-3076"><a href="https://www.apeshit.org/blog/">Blog</a></li>
<li class="page_item page-item-1984"><a href="https://www.apeshit.org/contact/">Contact</a></li>
<li class="page_item page-item-3199"><a href="https://www.apeshit.org/twitter/">Twitter</a></li>
</ul></div>
		</nav><!-- #access -->
	</header><!-- #branding -->

	<div id="main">
		<div id="primary">
			<div id="content" role="main">

			
					<nav id="nav-above">
		<h1 class="assistive-text section-heading">Post navigation</h1>

	
				<div class="nav-previous"><a href="https://www.apeshit.org/page/2/?busteefol_xml" ><span class="meta-nav">&larr;</span> Older posts</a></div>
		
		
	
	</nav><!-- #nav-above -->
	
								
					
<article id="post-11263" class="post-11263 post type-post status-publish format-standard hentry category-news tag-anders-odden tag-cadaver tag-carcass tag-dirk-verbeuren tag-jeff-walker tag-megadeth tag-nuclear-blast tag-satyricon tag-soilwork">
	<header class="entry-header">
		<h1 class="entry-title"><a href="https://www.apeshit.org/news/stream-the-new-cadaver-ep-d-g-a-f/" title="Permalink to Stream the New CADAVER EP, D.G.A.F." rel="bookmark">Stream the New CADAVER EP, <i>D.G.A.F.</i></a></h1>

				<div class="entry-meta">
			<span class="sep">Posted on </span><a href="https://www.apeshit.org/news/stream-the-new-cadaver-ep-d-g-a-f/" title="4:53 pm" rel="bookmark"><time class="entry-date" datetime="2020-04-19T16:53:00-08:00" pubdate>April 19, 2020</time></a><span class="byline"> <span class="sep"> by </span> <span class="author vcard"><a class="url fn n" href="https://www.apeshit.org/author/hdpark/" title="View all posts by dr.park" rel="author">dr.park</a></span></span>		</div><!-- .entry-meta -->
			</header><!-- .entry-header -->

		<div class="entry-content">
		
<figure class="wp-block-image"><img decoding="async" src="https://scontent-lax3-2.xx.fbcdn.net/v/t1.0-0/p640x640/67630030_2672890262730495_1921413831012122624_o.jpg?_nc_cat=107&amp;_nc_sid=8024bb&amp;_nc_ohc=84LJ544qt9QAX-aw-qS&amp;_nc_ht=scontent-lax3-2.xx&amp;_nc_tp=6&amp;oh=6a1dd9990c0f8b40330a8ed64152326f&amp;oe=5EC27F7C" alt=""/><figcaption>Photo credit: Hannah Verbeuren</figcaption></figure>



<p>Old school Norwegian death metal band, <strong><a href="https://www.facebook.com/cadavertheband/">CADAVER</a></strong>, have unleashed their new EP, <strong><em>D.G.A.F.</em></strong>, via their new label, <strong>Nuclear Blast</strong>. The band features founding member, <strong>Anders Odden</strong> (vocals/guitar/bass), and <strong>Dirk Verbeuren</strong> (drums).  </p>



<p><strong><em>D.G.A.F. </em></strong>can be streamed on <a href="http://nblast.de/CadaverDGAF">various platforms</a>.  Check out the title track, which features <strong>CARCASS</strong>&#8216; <strong>Jeff Walker</strong> on guest vocals:</p>



<figure class="wp-block-embed-youtube wp-block-embed is-type-video is-provider-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<span class="embed-youtube" style="text-align:center; display: block;"><iframe loading="lazy" class="youtube-player" width="640" height="360" src="https://www.youtube.com/embed/MAmUcGZHCa8?version=3&#038;rel=1&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;fs=1&#038;hl=en-US&#038;autohide=2&#038;wmode=transparent" allowfullscreen="true" style="border:0;" sandbox="allow-scripts allow-same-origin allow-popups allow-presentation"></iframe></span>
</div><figcaption><br /></figcaption></figure>



<p>In upcoming events, the band will be hosting a live Q&amp;A with fans on <a href="https://www.instagram.com/cadavertheband/?fbclid=IwAR3QSbtpPV_49h9AEi5_n85XdcDT3no11YpClIxMV6iacwZBHrpFtoTUyFI">Instagram</a> on Thursday, April 23rd at 11 am PST/8 pm CET.</p>
			</div><!-- .entry-content -->
	
	<footer class="entry-meta">
								<span class="cat-links">
				Posted in <a href="https://www.apeshit.org/category/news/" rel="category tag">News</a>			</span>
			<span class="sep"> | </span>
			
						<span class="tag-links">
				Tagged <a href="https://www.apeshit.org/tag/anders-odden/" rel="tag">anders odden</a>, <a href="https://www.apeshit.org/tag/cadaver/" rel="tag">cadaver</a>, <a href="https://www.apeshit.org/tag/carcass/" rel="tag">carcass</a>, <a href="https://www.apeshit.org/tag/dirk-verbeuren/" rel="tag">dirk-verbeuren</a>, <a href="https://www.apeshit.org/tag/jeff-walker/" rel="tag">jeff-walker</a>, <a href="https://www.apeshit.org/tag/megadeth/" rel="tag">megadeth</a>, <a href="https://www.apeshit.org/tag/nuclear-blast/" rel="tag">nuclear blast</a>, <a href="https://www.apeshit.org/tag/satyricon/" rel="tag">satyricon</a>, <a href="https://www.apeshit.org/tag/soilwork/" rel="tag">soilwork</a>			</span>
			<span class="sep"> | </span>
					
				<span class="comments-link"><a href="https://www.apeshit.org/news/stream-the-new-cadaver-ep-d-g-a-f/#comments">234,463 Comments</a></span>
		<span class="sep"> | </span>
		
			</footer><!-- #entry-meta -->
</article><!-- #post-11263 -->

				
					
<article id="post-11250" class="post-11250 post type-post status-publish format-standard hentry category-news tag-nuclearblast tag-vader">
	<header class="entry-header">
		<h1 class="entry-title"><a href="https://www.apeshit.org/news/video-of-the-day-vader-is-still-slaying-on-album-no-16/" title="Permalink to Video of the Day: VADER is Still Slaying on Album No. 16" rel="bookmark">Video of the Day: VADER is Still Slaying on Album No. 16</a></h1>

				<div class="entry-meta">
			<span class="sep">Posted on </span><a href="https://www.apeshit.org/news/video-of-the-day-vader-is-still-slaying-on-album-no-16/" title="9:58 am" rel="bookmark"><time class="entry-date" datetime="2020-04-03T09:58:37-08:00" pubdate>April 3, 2020</time></a><span class="byline"> <span class="sep"> by </span> <span class="author vcard"><a class="url fn n" href="https://www.apeshit.org/author/hdpark/" title="View all posts by dr.park" rel="author">dr.park</a></span></span>		</div><!-- .entry-meta -->
			</header><!-- .entry-header -->

		<div class="entry-content">
		
<p>The kings of Polish death metal, <strong><a href="https://www.youtube.com/channel/UCfsUPHDUxALBgo0kutfO0RA?sub_confirmation=1">VADER</a></strong>, are set to release their 16th album, <strong><em><a href="https://shop.nuclearblast.com/en/shop/item/groups/51000.1.html?article_group_sort_type_handle=rank&amp;custom_keywords=vader&amp;utm_campaign=&amp;utm_source=&amp;utm_medium=&amp;utm_content=&amp;utm_term=">Solitude in Madness</a></em></strong>, on May 1, 2020 via <strong>Nuclear Blast</strong>.  Their view for the song, &#8220;<strong>Into Oblivion</strong>,&#8221; has just been released and clearly shows that the band are as sharp as they ever were.  Enjoy this short, but sweet number.</p>



<figure class="wp-block-embed-youtube wp-block-embed is-type-video is-provider-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<span class="embed-youtube" style="text-align:center; display: block;"><iframe loading="lazy" class="youtube-player" width="640" height="360" src="https://www.youtube.com/embed/jVtC6a_YJV0?version=3&#038;rel=1&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;fs=1&#038;hl=en-US&#038;autohide=2&#038;wmode=transparent" allowfullscreen="true" style="border:0;" sandbox="allow-scripts allow-same-origin allow-popups allow-presentation"></iframe></span>
</div></figure>



<div class="wp-block-image"><figure class="aligncenter"><img decoding="async" loading="lazy" width="400" height="400" src="http://www.apeshit.org/images/2020/04/vader.solitudeinmadness-e1585936595984.jpg" alt="" class="wp-image-11251"/></figure></div>
			</div><!-- .entry-content -->
	
	<footer class="entry-meta">
								<span class="cat-links">
				Posted in <a href="https://www.apeshit.org/category/news/" rel="category tag">News</a>			</span>
			<span class="sep"> | </span>
			
						<span class="tag-links">
				Tagged <a href="https://www.apeshit.org/tag/nuclearblast/" rel="tag">nuclearblast</a>, <a href="https://www.apeshit.org/tag/vader/" rel="tag">vader</a>			</span>
			<span class="sep"> | </span>
					
				<span class="comments-link"><a href="https://www.apeshit.org/news/video-of-the-day-vader-is-still-slaying-on-album-no-16/#comments">34,441 Comments</a></span>
		<span class="sep"> | </span>
		
			</footer><!-- #entry-meta -->
</article><!-- #post-11250 -->

				
					
<article id="post-11234" class="post-11234 post type-post status-publish format-standard hentry category-reviews tag-sepultura">
	<header class="entry-header">
		<h1 class="entry-title"><a href="https://www.apeshit.org/reviews/sepultura-quadra/" title="Permalink to SEPULTURA &#8211; Quadra" rel="bookmark">SEPULTURA &#8211; <i>Quadra</i></a></h1>

				<div class="entry-meta">
			<span class="sep">Posted on </span><a href="https://www.apeshit.org/reviews/sepultura-quadra/" title="5:32 pm" rel="bookmark"><time class="entry-date" datetime="2020-02-26T17:32:49-08:00" pubdate>February 26, 2020</time></a><span class="byline"> <span class="sep"> by </span> <span class="author vcard"><a class="url fn n" href="https://www.apeshit.org/author/big-johnson/" title="View all posts by big johnson" rel="author">big johnson</a></span></span>		</div><!-- .entry-meta -->
			</header><!-- .entry-header -->

		<div class="entry-content">
		
<div class="wp-block-image"><figure class="alignright"><img decoding="async" loading="lazy" width="330" height="330" src="http://www.apeshit.org/images/2020/02/septultura.quadra.jpg" alt="" class="wp-image-11237" srcset="http://www.apeshit.org/images/2020/02/septultura.quadra.jpg 330w, http://www.apeshit.org/images/2020/02/septultura.quadra-150x150.jpg 150w, http://www.apeshit.org/images/2020/02/septultura.quadra-300x300.jpg 300w" sizes="(max-width: 330px) 100vw, 330px" /></figure></div>



<p><strong>SEPULTURA</strong>&nbsp;certainly needs no introduction, but to this day,&nbsp;<strong>Max Cavalera</strong>-fanboys still slam this lineup as a “cover band” and continue to bash every album released after&nbsp;<strong><em>Roots</em></strong>.&nbsp;&nbsp;While there were indeed a few lackluster albums after&nbsp;<strong>Max</strong>’s split,&nbsp;<strong><em>Machine Messiah</em></strong>&nbsp;showed some real potential for the band to finally crawl out of his shadow.&nbsp;&nbsp;<strong><em>Quadra</em></strong>, however, finally allows this band to break free and show some real grit and passion that was previously missing.</p>



<p>After a melodic start that is somewhat reminiscent of “<strong>Inquisition Symphony</strong>,” upon the first few notes you quickly realize that&nbsp;<strong><em>Quadra</em></strong>&nbsp;is different from the other&nbsp;<strong>Derrick Green</strong>-fronted albums.&nbsp;&nbsp;Could it be?&nbsp;&nbsp;Some brutality?&nbsp;&nbsp;Pissed off aggression?&nbsp;&nbsp;“<strong>Isolation</strong>” immediately punches you in the face with catchy, thrashy riffs the band was once known for.</p>



<p>Right away it’s apparent that drummer&nbsp;<strong>Eloy Casagrande</strong>&nbsp;is allowed to breathe artistically and fully showcase his talents.&nbsp;&nbsp;<strong>Casagrande</strong>&nbsp;is not confined as the last few albums he played on, and his freedom to go apeshit (pun intended) is finally unleashed.&nbsp;&nbsp;&nbsp;<strong>Igor Cavalera</strong>’s style is captured with&nbsp;<strong>Casagrande</strong>&nbsp;on “<strong>Means to an End</strong>” and he pays homage quite well.</p>



<figure class="wp-block-embed-youtube wp-block-embed is-type-video is-provider-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<span class="embed-youtube" style="text-align:center; display: block;"><iframe loading="lazy" class="youtube-player" width="640" height="360" src="https://www.youtube.com/embed/fJPuijhnXrA?version=3&#038;rel=1&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;fs=1&#038;hl=en-US&#038;autohide=2&#038;wmode=transparent" allowfullscreen="true" style="border:0;" sandbox="allow-scripts allow-same-origin allow-popups allow-presentation"></iframe></span>
</div></figure>



<p>“<strong>Last Time</strong>” provides the aggressiveness that was lacking in a lot of the recent albums, but the progression is quite clear with choirs, melodic solos, and all-around excellent songwriting.&nbsp;&nbsp;&nbsp;Shockingly, you’re still taken aback at how much firepower is on this album as the band takes no prisoners with the aural assault.</p>



<p>A lot of throwback ideas are on display, such as the tribal&nbsp;<strong><em>Roots</em></strong>-era influences on tracks like “<strong>Capital Enslavement</strong>.”&nbsp;&nbsp;&nbsp;The revitalization of the band is apparent and the refreshing thrash goodness is continued on “<strong>Ali</strong>.”&nbsp;</p>



<p>“<strong>Guardians of Earth</strong>” starts off with a well-placed acoustic guitar intro before leading into some choirs, killer solos by&nbsp;<strong>Andreas Kisser</strong>, before transitioning to the equally epic next track.&nbsp;&nbsp;“<strong>The Pentagram</strong>” is a track that absolutely could have been released in the&nbsp;<strong><em>Arise</em></strong>-era with&nbsp;<strong>Igor Cavalera</strong>-drum worship, flawless ripping and shredding and more and more riffs!&nbsp; The almost jam-like session has an abundance of&nbsp;brutal, almost death metal inspired riffs, and&nbsp;<strong><em>Quadra</em></strong>&nbsp;reaches its apex at this point.&nbsp;</p>



<figure class="wp-block-embed-youtube wp-block-embed is-type-video is-provider-youtube wp-embed-aspect-4-3 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<span class="embed-youtube" style="text-align:center; display: block;"><iframe loading="lazy" class="youtube-player" width="640" height="360" src="https://www.youtube.com/embed/-czH8TO_7kk?version=3&#038;rel=1&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;fs=1&#038;hl=en-US&#038;autohide=2&#038;wmode=transparent" allowfullscreen="true" style="border:0;" sandbox="allow-scripts allow-same-origin allow-popups allow-presentation"></iframe></span>
</div></figure>



<p>The album drops off a bit towards the end, but this effort is most definitely the best material since <strong><em>Roots</em></strong>.&nbsp;&nbsp;<strong>Jens Bogren</strong>&nbsp;once again shines in the producer seat, as the guitar crunch and heaviness of the drums are mixed perfectly without being buried in the mix of the constant barrage of&nbsp;<strong>Green</strong>’s vocals.</p>



<p>While the days of an all out thrash attack like&nbsp;<strong><em>Beneath the Remains</em></strong>&nbsp;are gone, the band as a whole has, dare we say progressed, and ultimately delivered a crushing album that rivals the ones at the pinnacle of their career in the early and mid-90’s.</p>



<p>Who needs a&nbsp;<strong>SEPULTURA</strong>&nbsp;reunion with&nbsp;<strong>Max</strong>&nbsp;when this album crushes anything&nbsp;<strong>SOULFLY</strong>&nbsp;has done in recent years?&nbsp;&nbsp;Huge respect goes out to&nbsp;<strong>Andreas, Derrick, Paulo,&nbsp;</strong>and<strong>&nbsp;Eloy</strong>, as&nbsp;<strong><em>Quadra</em></strong> has already set the precedence for album of the year. (<strong>Nuclear Blast Records</strong>)</p>
			</div><!-- .entry-content -->
	
	<footer class="entry-meta">
								<span class="cat-links">
				Posted in <a href="https://www.apeshit.org/category/reviews/" rel="category tag">Reviews</a>			</span>
			<span class="sep"> | </span>
			
						<span class="tag-links">
				Tagged <a href="https://www.apeshit.org/tag/sepultura/" rel="tag">sepultura</a>			</span>
			<span class="sep"> | </span>
					
				<span class="comments-link"><a href="https://www.apeshit.org/reviews/sepultura-quadra/#comments">17,677 Comments</a></span>
		<span class="sep"> | </span>
		
			</footer><!-- #entry-meta -->
</article><!-- #post-11234 -->

				
					
<article id="post-11203" class="post-11203 post type-post status-publish format-standard hentry category-features tag-dunableguitars tag-espguitars tag-exodus tag-gibsonguitars tag-ironmaiden tag-jacksonguitars tag-namm tag-namm2020 tag-nickomcbrain tag-ormsbyguitars tag-sabian tag-slayer tag-strandberguitars">
	<header class="entry-header">
		<h1 class="entry-title"><a href="https://www.apeshit.org/features/national-association-of-music-merchants-namm-2020-show-report/" title="Permalink to National Association of Music Merchants (NAMM) 2020 Show Report" rel="bookmark">National Association of Music Merchants (NAMM) 2020 Show Report</a></h1>

				<div class="entry-meta">
			<span class="sep">Posted on </span><a href="https://www.apeshit.org/features/national-association-of-music-merchants-namm-2020-show-report/" title="3:15 pm" rel="bookmark"><time class="entry-date" datetime="2020-02-23T15:15:13-08:00" pubdate>February 23, 2020</time></a><span class="byline"> <span class="sep"> by </span> <span class="author vcard"><a class="url fn n" href="https://www.apeshit.org/author/big-johnson/" title="View all posts by big johnson" rel="author">big johnson</a></span></span>		</div><!-- .entry-meta -->
			</header><!-- .entry-header -->

		<div class="entry-content">
		
<figure class="wp-block-image"><img decoding="async" loading="lazy" width="768" height="1024" src="http://www.apeshit.org/images/2020/02/dunableguitars.namm2020-768x1024.jpg" alt="" class="wp-image-11221" srcset="http://www.apeshit.org/images/2020/02/dunableguitars.namm2020.jpg 768w, http://www.apeshit.org/images/2020/02/dunableguitars.namm2020-225x300.jpg 225w" sizes="(max-width: 768px) 100vw, 768px" /></figure>



<p>Hails to all you&nbsp;<strong>APESHIT</strong>&nbsp;goons, has it been a year already?&nbsp;&nbsp;How time flies when you’re blasting underground metal on a daily basis.&nbsp;&nbsp;We hit up the <strong>Winter NAMM</strong> show, and here are a few things we found interesting in 2020!</p>



<p><strong>Sabian&#8217;s</strong> new printed graphic cymbals made their debut, and they are quite a delight to enhance your kit’s visual appeal.  These printed cymbals are available at their custom shop, as the tops are printed with a color graphic, and the bottom is left untreated.   Another notable new <strong>Sabian </strong>product is the crisp <strong>Complex</strong> 21” and 22” ride that ensures to cut through your run-of-the-mill grind riffs. We recommend getting the <a href="https://observer.com/2021/01/best-true-wireless-earbuds-of-2020/">Best wireless earbuds </a>to enjoy your favorite artists and bands.</p>



<p>Getting rid of body hair has been part of our routines for a long time. Guys shave their facial hair, and women shave their legs and underarms. Normally are 2 the types of treatment that you prefer to employ, but which one is the best? <a href="http://www.smallnhot.com/2018/12/epilator-vs-waxing-which-is-right-for.html">epilator vs waxing</a>!</p>



<figure class="wp-block-image"><img decoding="async" loading="lazy" width="800" height="600" src="http://www.apeshit.org/images/2020/02/nickmcbraindrumkit.jpg" alt="" class="wp-image-11220" srcset="http://www.apeshit.org/images/2020/02/nickmcbraindrumkit.jpg 800w, http://www.apeshit.org/images/2020/02/nickmcbraindrumkit-300x225.jpg 300w, http://www.apeshit.org/images/2020/02/nickmcbraindrumkit-768x576.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></figure>



<p>Drum god&nbsp;<strong>Nicko McBrain (IRON MAIDEN)</strong>&nbsp;has switched over to the&nbsp;<strong>British Drum Co.</strong>&nbsp;with his custom <strong>Icarus</strong> kit.&nbsp;&nbsp;The <strong>Icarus</strong>&nbsp;features a signature snare series that has an Oak shell with Black Fishtail Oak outer veneer and the&nbsp;<strong>Icarus</strong>&nbsp;logo badge on the side.&nbsp;&nbsp;The kit can be ordered as a replica or in any size configuration, which should please drummers who are huge&nbsp;<strong>Nicko McBrain/IRON MAIDEN</strong>&nbsp;fans.</p>



<p> <a href="https://www.apeshit.org/features/national-association-of-music-merchants-namm-2020-show-report/#more-11203" class="more-link">Continue reading <span class="meta-nav">&rarr;</span></a></p>			</div><!-- .entry-content -->
	
	<footer class="entry-meta">
								<span class="cat-links">
				Posted in <a href="https://www.apeshit.org/category/features/" rel="category tag">Features</a>			</span>
			<span class="sep"> | </span>
			
						<span class="tag-links">
				Tagged <a href="https://www.apeshit.org/tag/dunableguitars/" rel="tag">dunableguitars</a>, <a href="https://www.apeshit.org/tag/espguitars/" rel="tag">espguitars</a>, <a href="https://www.apeshit.org/tag/exodus/" rel="tag">exodus</a>, <a href="https://www.apeshit.org/tag/gibsonguitars/" rel="tag">gibsonguitars</a>, <a href="https://www.apeshit.org/tag/ironmaiden/" rel="tag">ironmaiden</a>, <a href="https://www.apeshit.org/tag/jacksonguitars/" rel="tag">jacksonguitars</a>, <a href="https://www.apeshit.org/tag/namm/" rel="tag">namm</a>, <a href="https://www.apeshit.org/tag/namm2020/" rel="tag">namm2020</a>, <a href="https://www.apeshit.org/tag/nickomcbrain/" rel="tag">nickomcbrain</a>, <a href="https://www.apeshit.org/tag/ormsbyguitars/" rel="tag">ormsbyguitars</a>, <a href="https://www.apeshit.org/tag/sabian/" rel="tag">sabian</a>, <a href="https://www.apeshit.org/tag/slayer/" rel="tag">slayer</a>, <a href="https://www.apeshit.org/tag/strandberguitars/" rel="tag">strandberguitars</a>			</span>
			<span class="sep"> | </span>
					
				<span class="comments-link"><a href="https://www.apeshit.org/features/national-association-of-music-merchants-namm-2020-show-report/#comments">10,632 Comments</a></span>
		<span class="sep"> | </span>
		
			</footer><!-- #entry-meta -->
</article><!-- #post-11203 -->

				
					
<article id="post-11193" class="post-11193 post type-post status-publish format-standard hentry category-reviews tag-defiled tag-wesbenscoter">
	<header class="entry-header">
		<h1 class="entry-title"><a href="https://www.apeshit.org/reviews/defiled-infinite-regress/" title="Permalink to DEFILED &#8211; Infinite Regress" rel="bookmark">DEFILED &#8211; <i>Infinite Regress</i></a></h1>

				<div class="entry-meta">
			<span class="sep">Posted on </span><a href="https://www.apeshit.org/reviews/defiled-infinite-regress/" title="9:58 am" rel="bookmark"><time class="entry-date" datetime="2020-02-07T09:58:43-08:00" pubdate>February 7, 2020</time></a><span class="byline"> <span class="sep"> by </span> <span class="author vcard"><a class="url fn n" href="https://www.apeshit.org/author/big-johnson/" title="View all posts by big johnson" rel="author">big johnson</a></span></span>		</div><!-- .entry-meta -->
			</header><!-- .entry-header -->

		<div class="entry-content">
		
<div class="wp-block-image"><figure class="alignright is-resized"><img decoding="async" loading="lazy" src="http://www.apeshit.org/images/2020/02/defiled.infiniteregress.jpg" alt="" class="wp-image-11194" width="300" height="300"/></figure></div>



<p>Japan’s unique death metal veterans,&nbsp;<strong><a href="https://defiledjapan.bandcamp.com/">DEFILED</a></strong>, have delivered a whopper of an album! Don’t believe me?&nbsp;&nbsp;Check out the video below.&nbsp;&nbsp;As always, the constant is guitarist&nbsp;<strong>Yusuke Sumita</strong>, and his chaotic riffs are on full display with an excellent complimentary lineup to forge his passion for underground death metal.</p>



<p>After the intro, <strong><em>Infinite Regress</em></strong> opens up with the dizzying track, “<strong>Divide and Conquer</strong>” and unloads a healthy mix of grind, blasts, and discordant riffs.  <strong>DEFILED</strong> is chock full of technical parts, but not the usual guitar noodling “sweep after sweep” garbage that has infiltrated the “technical metal” subgenre these days.</p>



<p>The production is hearty and crisp, without sacrificing any distortion crunch or having the drums getting buried in the mix.  However, don’t think this album is just a blast fest, as “<strong>Tragedy</strong>” starts with a mid-paced slew of riffs before showing their trademark off-time riffs and maniacal vocal lines.</p>



<p>Some great bass lines are thrown in “<strong>Aftermath</strong>,” and <strong>DEFILED</strong>’s catchiest material to date is offered here on tracks such as “<strong>Systematic Decomposition</strong>,”  “<strong>Masses in Chaos</strong>,” and “<strong>Slaverobot</strong>.”</p>



<p><strong>DEFILED</strong> is a band that takes multiple listens before appreciating the whirlwind riffs and savagery of it all, and this album is no different.  So many riffs are unleashed everywhere but somehow it all comes together nicely with different tempo changes and great drum patterns.  The band should be extremely proud of this effort, and fans of classic riffage influenced by <strong>NAPALM DEATH</strong>, <strong>TERRORIZER</strong>, <strong>CRYPTOPSY </strong>(just to name a few) should enjoy this album immensely.  Last but not least, the sick work of <strong>Wes Benscoter</strong> graces the cover and solidifies this album as a great pick up in 2020. (<strong>Season of Mist</strong>)</p>



<figure class="wp-block-embed-youtube wp-block-embed is-type-video is-provider-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<span class="embed-youtube" style="text-align:center; display: block;"><iframe loading="lazy" class="youtube-player" width="640" height="360" src="https://www.youtube.com/embed/Nqq-NJNQNd8?version=3&#038;rel=1&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;fs=1&#038;hl=en-US&#038;autohide=2&#038;wmode=transparent" allowfullscreen="true" style="border:0;" sandbox="allow-scripts allow-same-origin allow-popups allow-presentation"></iframe></span>
</div></figure>
			</div><!-- .entry-content -->
	
	<footer class="entry-meta">
								<span class="cat-links">
				Posted in <a href="https://www.apeshit.org/category/reviews/" rel="category tag">Reviews</a>			</span>
			<span class="sep"> | </span>
			
						<span class="tag-links">
				Tagged <a href="https://www.apeshit.org/tag/defiled/" rel="tag">defiled</a>, <a href="https://www.apeshit.org/tag/wesbenscoter/" rel="tag">wesbenscoter</a>			</span>
			<span class="sep"> | </span>
					
				<span class="comments-link"><a href="https://www.apeshit.org/reviews/defiled-infinite-regress/#comments">13,653 Comments</a></span>
		<span class="sep"> | </span>
		
			</footer><!-- #entry-meta -->
</article><!-- #post-11193 -->

				
					
<article id="post-11188" class="post-11188 post type-post status-publish format-standard hentry category-news tag-cynic tag-death tag-seanreinhert">
	<header class="entry-header">
		<h1 class="entry-title"><a href="https://www.apeshit.org/news/sean-reinhert-rip-1971-2020/" title="Permalink to Sean Reinhert – RIP 1971-2020" rel="bookmark">Sean Reinhert – RIP 1971-2020</a></h1>

				<div class="entry-meta">
			<span class="sep">Posted on </span><a href="https://www.apeshit.org/news/sean-reinhert-rip-1971-2020/" title="9:47 am" rel="bookmark"><time class="entry-date" datetime="2020-02-07T09:47:02-08:00" pubdate>February 7, 2020</time></a><span class="byline"> <span class="sep"> by </span> <span class="author vcard"><a class="url fn n" href="https://www.apeshit.org/author/big-johnson/" title="View all posts by big johnson" rel="author">big johnson</a></span></span>		</div><!-- .entry-meta -->
			</header><!-- .entry-header -->

		<div class="entry-content">
		
<div class="wp-block-image"><figure class="alignright"><img decoding="async" loading="lazy" width="236" height="309" src="http://www.apeshit.org/images/2020/02/seanreinhert.jpg" alt="" class="wp-image-11190" srcset="http://www.apeshit.org/images/2020/02/seanreinhert.jpg 236w, http://www.apeshit.org/images/2020/02/seanreinhert-229x300.jpg 229w" sizes="(max-width: 236px) 100vw, 236px" /></figure></div>



<p>The debate over which&nbsp;<strong>DEATH</strong>&nbsp;album is the best will have various results, depending on who you ask.&nbsp;&nbsp;Some swear by the sheer brutality and simplicity of&nbsp;<strong><em>Scream Bloody Gore</em></strong>, or the ultra-catchy riffs from&nbsp;<strong><em>Leprosy</em></strong>.&nbsp;&nbsp;Some guitar enthusiasts enjoy&nbsp;<strong><em>Spiritual Healing</em></strong>&nbsp;the most because of&nbsp;<strong>James Murphy</strong>’s wizardry, but my personal favorite will always be&nbsp;<strong><em>Human</em></strong>, simply because of the flawless performance by&nbsp;<strong>Sean Reinert</strong>.&nbsp;&nbsp;The album opens with the obvious focus on&nbsp;<strong>Reinert</strong>’s talent as the double bass crescendos into some toms and then…brutality.&nbsp;&nbsp;The rest of the album never lets up, and while&nbsp;<strong>Chuck Schuldiner</strong>’s riffs and leads are in top form, to me, it’s&nbsp;<strong>Reinert</strong>’s execution that makes this album one of the ultimate death metal albums of all time.</p>



<p></p>



<p>The technicality of well-placed cymbal hits, rides, complex drum patterns are so succinct and perfect, that it honestly takes tens of listens before you can fully comprehend and appreciate the greatness that&nbsp;<strong>Reinert</strong>&nbsp;infused on every album he’s played on.&nbsp;&nbsp;Not only did he implement such a brutal touch on the album, but his jazzy influence was well-documented as well, especially on the track “Cosmic Sea.”&nbsp;&nbsp;Admittedly, I was not a fan of&nbsp;<strong>CYNIC</strong>&nbsp;when&nbsp;<strong><em>Focus</em></strong>&nbsp;was first released, but after I heard&nbsp;<strong><em>Human</em></strong>, I decided to revisit the album and once again, realized the sheer genius that&nbsp;<strong>Reinert</strong>&nbsp;facilitated.</p>



<p>On a personal level, I only met him for a few minutes on two separate occasions, but he was a genuine and extremely kind person.&nbsp;&nbsp;He was appreciative that I had almost everything he had played on and was very humble about it all.</p>



<p>Our condolences go out to his husband, family, and his friends.&nbsp;&nbsp;The music and metal scene has lost one of the greatest game changers in drumming history.</p>



<figure class="wp-block-embed-youtube wp-block-embed is-type-video is-provider-youtube wp-embed-aspect-4-3 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<span class="embed-youtube" style="text-align:center; display: block;"><iframe loading="lazy" class="youtube-player" width="640" height="360" src="https://www.youtube.com/embed/XZH_58MeNF4?version=3&#038;rel=1&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;fs=1&#038;hl=en-US&#038;autohide=2&#038;wmode=transparent&#038;listType=playlist&#038;list=PLiLDkNTiyE1zNECkmCuiXZX2VSCMwEDoa" allowfullscreen="true" style="border:0;" sandbox="allow-scripts allow-same-origin allow-popups allow-presentation"></iframe></span>
</div></figure>
			</div><!-- .entry-content -->
	
	<footer class="entry-meta">
								<span class="cat-links">
				Posted in <a href="https://www.apeshit.org/category/news/" rel="category tag">News</a>			</span>
			<span class="sep"> | </span>
			
						<span class="tag-links">
				Tagged <a href="https://www.apeshit.org/tag/cynic/" rel="tag">cynic</a>, <a href="https://www.apeshit.org/tag/death/" rel="tag">death</a>, <a href="https://www.apeshit.org/tag/seanreinhert/" rel="tag">seanreinhert</a>			</span>
			<span class="sep"> | </span>
					
				<span class="comments-link"><a href="https://www.apeshit.org/news/sean-reinhert-rip-1971-2020/#comments">13,873 Comments</a></span>
		<span class="sep"> | </span>
		
			</footer><!-- #entry-meta -->
</article><!-- #post-11188 -->

				
					
<article id="post-11169" class="post-11169 post type-post status-publish format-standard hentry category-news tag-mayhem">
	<header class="entry-header">
		<h1 class="entry-title"><a href="https://www.apeshit.org/news/listen-to-new-track-from-mayhems-upcoming-daemon/" title="Permalink to Listen to New Track from MAYHEM&#8217;s Upcoming, Daemon" rel="bookmark">Listen to New Track from MAYHEM&#8217;s Upcoming, <i>Daemon</i></a></h1>

				<div class="entry-meta">
			<span class="sep">Posted on </span><a href="https://www.apeshit.org/news/listen-to-new-track-from-mayhems-upcoming-daemon/" title="11:02 am" rel="bookmark"><time class="entry-date" datetime="2019-08-30T11:02:56-08:00" pubdate>August 30, 2019</time></a><span class="byline"> <span class="sep"> by </span> <span class="author vcard"><a class="url fn n" href="https://www.apeshit.org/author/hdpark/" title="View all posts by dr.park" rel="author">dr.park</a></span></span>		</div><!-- .entry-meta -->
			</header><!-- .entry-header -->

		<div class="entry-content">
		
<p>The first song to be released from <strong>MAYHEM</strong>&#8216;s <strong><em>Daemon</em></strong>, entitled &#8220;<strong><em>Worthless Abominations Destroyed</em></strong> &#8221; has been posted online:</p>



<figure class="wp-block-embed-youtube wp-block-embed is-type-video is-provider-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<span class="embed-youtube" style="text-align:center; display: block;"><iframe loading="lazy" class="youtube-player" width="640" height="360" src="https://www.youtube.com/embed/FzT1vRXsHoo?version=3&#038;rel=1&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;fs=1&#038;hl=en-US&#038;autohide=2&#038;wmode=transparent" allowfullscreen="true" style="border:0;" sandbox="allow-scripts allow-same-origin allow-popups allow-presentation"></iframe></span>
</div></figure>



<p>The song carries the mystique, mystery, and feel of the band&#8217;s early work, specifically, <strong><em>De Mysteriis Dom Sathanas</em></strong>.  <strong><em>Daemon</em></strong> should be another masterpiece.</p>
			</div><!-- .entry-content -->
	
	<footer class="entry-meta">
								<span class="cat-links">
				Posted in <a href="https://www.apeshit.org/category/news/" rel="category tag">News</a>			</span>
			<span class="sep"> | </span>
			
						<span class="tag-links">
				Tagged <a href="https://www.apeshit.org/tag/mayhem/" rel="tag">mayhem</a>			</span>
			<span class="sep"> | </span>
					
				<span class="comments-link"><a href="https://www.apeshit.org/news/listen-to-new-track-from-mayhems-upcoming-daemon/#comments">17,920 Comments</a></span>
		<span class="sep"> | </span>
		
			</footer><!-- #entry-meta -->
</article><!-- #post-11169 -->

				
					
<article id="post-11126" class="post-11126 post type-post status-publish format-standard hentry category-features tag-anthrax tag-arch-enemy tag-dino-cazares tag-dirk-verbeuren tag-esp-guitars tag-fear-factory tag-henry-rollins tag-immolation tag-jackson-guitars tag-jeff-loomis tag-kiesel-guitars tag-megadeth tag-namm tag-national-association-of-music-merchants tag-ormsby tag-rollins-band tag-sabian tag-shure tag-tama tag-vio-lence">
	<header class="entry-header">
		<h1 class="entry-title"><a href="https://www.apeshit.org/features/national-association-of-music-merchants-namm-2019-show-report/" title="Permalink to National Association of Music Merchants (NAMM) 2019 Show Report" rel="bookmark">National Association of Music Merchants (NAMM) 2019 Show Report</a></h1>

				<div class="entry-meta">
			<span class="sep">Posted on </span><a href="https://www.apeshit.org/features/national-association-of-music-merchants-namm-2019-show-report/" title="2:44 pm" rel="bookmark"><time class="entry-date" datetime="2019-03-08T14:44:05-08:00" pubdate>March 8, 2019</time></a><span class="byline"> <span class="sep"> by </span> <span class="author vcard"><a class="url fn n" href="https://www.apeshit.org/author/big-johnson/" title="View all posts by big johnson" rel="author">big johnson</a></span></span>		</div><!-- .entry-meta -->
			</header><!-- .entry-header -->

		<div class="entry-content">
		<p><img decoding="async" loading="lazy" class="alignnone size-large wp-image-11129" src="http://www.apeshit.org/images/2019/03/dirkverbeuren.namm_-1-1024x1000.jpg" alt="" width="640" height="625" srcset="http://www.apeshit.org/images/2019/03/dirkverbeuren.namm_-1-1024x1000.jpg 1024w, http://www.apeshit.org/images/2019/03/dirkverbeuren.namm_-1-300x293.jpg 300w, http://www.apeshit.org/images/2019/03/dirkverbeuren.namm_-1-768x750.jpg 768w, http://www.apeshit.org/images/2019/03/dirkverbeuren.namm_-1.jpg 2028w" sizes="(max-width: 640px) 100vw, 640px" />Greetings and salutations from sunny California!  Once again, another amazing <strong>National Association of Music Merchants</strong> (<strong>NAMM</strong>) convention has come and gone!  There were a few surprises along the way, they also had the <a href="https://www.mobilemusicphilly.com/lessons.html">Free Music Lesson</a>, and as always, we had a great time checking out all the gear!</p>
<p> <a href="https://www.apeshit.org/features/national-association-of-music-merchants-namm-2019-show-report/#more-11126" class="more-link">Continue reading <span class="meta-nav">&rarr;</span></a></p>
			</div><!-- .entry-content -->
	
	<footer class="entry-meta">
								<span class="cat-links">
				Posted in <a href="https://www.apeshit.org/category/features/" rel="category tag">Features</a>			</span>
			<span class="sep"> | </span>
			
						<span class="tag-links">
				Tagged <a href="https://www.apeshit.org/tag/anthrax/" rel="tag">anthrax</a>, <a href="https://www.apeshit.org/tag/arch-enemy/" rel="tag">arch-enemy</a>, <a href="https://www.apeshit.org/tag/dino-cazares/" rel="tag">dino-cazares</a>, <a href="https://www.apeshit.org/tag/dirk-verbeuren/" rel="tag">dirk-verbeuren</a>, <a href="https://www.apeshit.org/tag/esp-guitars/" rel="tag">esp guitars</a>, <a href="https://www.apeshit.org/tag/fear-factory/" rel="tag">fear-factory</a>, <a href="https://www.apeshit.org/tag/henry-rollins/" rel="tag">henry rollins</a>, <a href="https://www.apeshit.org/tag/immolation/" rel="tag">immolation</a>, <a href="https://www.apeshit.org/tag/jackson-guitars/" rel="tag">jackson guitars</a>, <a href="https://www.apeshit.org/tag/jeff-loomis/" rel="tag">jeff-loomis</a>, <a href="https://www.apeshit.org/tag/kiesel-guitars/" rel="tag">kiesel guitars</a>, <a href="https://www.apeshit.org/tag/megadeth/" rel="tag">megadeth</a>, <a href="https://www.apeshit.org/tag/namm/" rel="tag">namm</a>, <a href="https://www.apeshit.org/tag/national-association-of-music-merchants/" rel="tag">national association of music merchants</a>, <a href="https://www.apeshit.org/tag/ormsby/" rel="tag">ormsby</a>, <a href="https://www.apeshit.org/tag/rollins-band/" rel="tag">rollins band</a>, <a href="https://www.apeshit.org/tag/sabian/" rel="tag">sabian</a>, <a href="https://www.apeshit.org/tag/shure/" rel="tag">shure</a>, <a href="https://www.apeshit.org/tag/tama/" rel="tag">tama</a>, <a href="https://www.apeshit.org/tag/vio-lence/" rel="tag">vio-lence</a>			</span>
			<span class="sep"> | </span>
					
				<span class="comments-link"><a href="https://www.apeshit.org/features/national-association-of-music-merchants-namm-2019-show-report/#comments">6,837 Comments</a></span>
		<span class="sep"> | </span>
		
			</footer><!-- #entry-meta -->
</article><!-- #post-11126 -->

				
					
<article id="post-11069" class="post-11069 post type-post status-publish format-standard hentry category-reviews tag-lee-harrison tag-monstrosity tag-morbid-angel tag-pete-sandoval tag-terrorizer">
	<header class="entry-header">
		<h1 class="entry-title"><a href="https://www.apeshit.org/reviews/terrorizer-caustic-attack/" title="Permalink to TERRORIZER &#8211; Caustic Attack" rel="bookmark">TERRORIZER &#8211; <i>Caustic Attack</i></a></h1>

				<div class="entry-meta">
			<span class="sep">Posted on </span><a href="https://www.apeshit.org/reviews/terrorizer-caustic-attack/" title="5:21 pm" rel="bookmark"><time class="entry-date" datetime="2019-01-31T17:21:58-08:00" pubdate>January 31, 2019</time></a><span class="byline"> <span class="sep"> by </span> <span class="author vcard"><a class="url fn n" href="https://www.apeshit.org/author/hdpark/" title="View all posts by dr.park" rel="author">dr.park</a></span></span>		</div><!-- .entry-meta -->
			</header><!-- .entry-header -->

		<div class="entry-content">
		<p><img decoding="async" loading="lazy" class="alignright size-full wp-image-11120" src="http://www.apeshit.org/images/2019/01/terrorizer.causticattack-1.jpg" alt="" width="200" height="200" srcset="http://www.apeshit.org/images/2019/01/terrorizer.causticattack-1.jpg 200w, http://www.apeshit.org/images/2019/01/terrorizer.causticattack-1-150x150.jpg 150w" sizes="(max-width: 200px) 100vw, 200px" />The world is always a better place when THE master blaster, <strong>Pete Sandoval</strong>, is actively playing music.  After overcoming the arduous journey back from back surgery, he teamed up with multi-instrumentalist <strong>Lee Harrison</strong> (<strong>MONSTROSITY</strong>) and vocalist <strong>Sam Molina</strong> (ex-<strong>MONSTROSITY</strong>) to revive <a href="https://www.facebook.com/terrorizerofficial"><strong>TERRORIZER</strong></a>.</p>
<p>The long and short of it is that <em><strong>Caustic Attack</strong></em> is the band&#8217;s best album since their infallible landmark debut, <em><strong>World Downfall</strong></em>. In fact, <em><strong>Caustic Attack</strong></em> is one of the top albums of 2018. All apologies to <strong>Lee</strong> but shit, we didn&#8217;t know he could bust out out such good riffs as he&#8217;s built his reputation as a drummer.</p>
<p>Getting back to the <strong>Commando</strong>, the beauty of <em><strong>Caustic Attack</strong></em> is that it can be thoroughly enjoyed in different ways.  You can enjoy the exciting, heart pumping songs themselves or you can just focus in on <strong>Pete</strong>&#8216;s drumming and just marvel at how he crushes all.</p>
<p><em><strong>Caustic Attack </strong></em>starts off with songs that are geared towards being album openers with lots of immediate blasting and catchy, simple riffs that carry more of a punk/grind feel.  Half way through the album with &#8220;<strong>Trench of Corruption</strong>,&#8221; things get more ominous and darker.  There is this tangible feeling of urgency and momentum that are undeniable.  And this is where <strong>TERRORIZER</strong> truly shine and separates itself from the pack.</p>
<p>Don&#8217;t deny yourself one of the best extreme metal albums in recent memory.  A new beginning is here for one of the godfathers.  Bow down.  (<strong>The End Records</strong>)</p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe loading="lazy" class="youtube-player" width="640" height="360" src="https://www.youtube.com/embed/wrzgHxf84jc?version=3&#038;rel=1&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;fs=1&#038;hl=en-US&#038;autohide=2&#038;wmode=transparent" allowfullscreen="true" style="border:0;" sandbox="allow-scripts allow-same-origin allow-popups allow-presentation"></iframe></span></p>
<p>&nbsp;</p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe loading="lazy" class="youtube-player" width="640" height="360" src="https://www.youtube.com/embed/Wbfdz7PozRQ?version=3&#038;rel=1&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;fs=1&#038;hl=en-US&#038;autohide=2&#038;wmode=transparent" allowfullscreen="true" style="border:0;" sandbox="allow-scripts allow-same-origin allow-popups allow-presentation"></iframe></span></p>
<p>&nbsp;</p>
<p>&nbsp;</p>
			</div><!-- .entry-content -->
	
	<footer class="entry-meta">
								<span class="cat-links">
				Posted in <a href="https://www.apeshit.org/category/reviews/" rel="category tag">Reviews</a>			</span>
			<span class="sep"> | </span>
			
						<span class="tag-links">
				Tagged <a href="https://www.apeshit.org/tag/lee-harrison/" rel="tag">lee harrison</a>, <a href="https://www.apeshit.org/tag/monstrosity/" rel="tag">monstrosity</a>, <a href="https://www.apeshit.org/tag/morbid-angel/" rel="tag">morbid-angel</a>, <a href="https://www.apeshit.org/tag/pete-sandoval/" rel="tag">pete sandoval</a>, <a href="https://www.apeshit.org/tag/terrorizer/" rel="tag">terrorizer</a>			</span>
			<span class="sep"> | </span>
					
				<span class="comments-link"><a href="https://www.apeshit.org/reviews/terrorizer-caustic-attack/#comments">12,536 Comments</a></span>
		<span class="sep"> | </span>
		
			</footer><!-- #entry-meta -->
</article><!-- #post-11069 -->

				
					
<article id="post-11116" class="post-11116 post type-post status-publish format-standard hentry category-blog tag-soulseller-records tag-ved-buens-ende">
	<header class="entry-header">
		<h1 class="entry-title"><a href="https://www.apeshit.org/blog/video-of-the-day-ved-buens-ende-quietly-reunites-for-show/" title="Permalink to Video of the Day: VED BUENS ENDE Quietly Reunites for Show" rel="bookmark">Video of the Day: VED BUENS ENDE Quietly Reunites for Show</a></h1>

				<div class="entry-meta">
			<span class="sep">Posted on </span><a href="https://www.apeshit.org/blog/video-of-the-day-ved-buens-ende-quietly-reunites-for-show/" title="2:56 pm" rel="bookmark"><time class="entry-date" datetime="2019-01-29T14:56:54-08:00" pubdate>January 29, 2019</time></a><span class="byline"> <span class="sep"> by </span> <span class="author vcard"><a class="url fn n" href="https://www.apeshit.org/author/hdpark/" title="View all posts by dr.park" rel="author">dr.park</a></span></span>		</div><!-- .entry-meta -->
			</header><!-- .entry-header -->

		<div class="entry-content">
		<p><img decoding="async" loading="lazy" class="alignnone size-large" src="http://www.soulsellerrecords.com/wp-content/uploads/2018/09/SSR120_real2.jpg" width="960" height="960" />The criminally underrated gods of Norwegian avant garde black metal, <a href="https://www.facebook.com/vedbuensende1/"><strong>VED BUENS ENDE</strong></a>, recently reunited to play a live show this past Saturday, January 26, 2019.  Check out this <a href="https://www.facebook.com/120105594669153/posts/2326935423986148/">short clip</a>.</p>
<p>Hopefully, this signals more to come from the band.  Last December, <strong>Soulseller Records</strong> reissued the long out-of-print masterpiece, <em><strong>Written in Waters</strong></em>, with the original artwork.  Check out the details <a href="http://www.soulsellerrecords.com/wp-content/uploads/2018/09/SSR120_real2.jpg">here</a>.</p>
			</div><!-- .entry-content -->
	
	<footer class="entry-meta">
								<span class="cat-links">
				Posted in <a href="https://www.apeshit.org/category/blog/" rel="category tag">Blog</a>			</span>
			<span class="sep"> | </span>
			
						<span class="tag-links">
				Tagged <a href="https://www.apeshit.org/tag/soulseller-records/" rel="tag">soulseller records</a>, <a href="https://www.apeshit.org/tag/ved-buens-ende/" rel="tag">ved-buens-ende</a>			</span>
			<span class="sep"> | </span>
					
				<span class="comments-link"><a href="https://www.apeshit.org/blog/video-of-the-day-ved-buens-ende-quietly-reunites-for-show/#comments">13,002 Comments</a></span>
		<span class="sep"> | </span>
		
			</footer><!-- #entry-meta -->
</article><!-- #post-11116 -->

				
					<nav id="nav-below">
		<h1 class="assistive-text section-heading">Post navigation</h1>

	
				<div class="nav-previous"><a href="https://www.apeshit.org/page/2/?busteefol_xml" ><span class="meta-nav">&larr;</span> Older posts</a></div>
		
		
	
	</nav><!-- #nav-below -->
	
			
			</div><!-- #content -->
		</div><!-- #primary -->

		<div id="secondary" class="widget-area" role="complementary">
						<aside id="search-2" class="widget widget_search"><form role="search" method="get" id="searchform" class="searchform" action="https://www.apeshit.org/">
				<div>
					<label class="screen-reader-text" for="s">Search for:</label>
					<input type="text" value="" name="s" id="s" />
					<input type="submit" id="searchsubmit" value="Search" />
				</div>
			</form></aside>		</div><!-- #secondary .widget-area -->

		
	</div><!-- #main -->

	<footer id="colophon" role="contentinfo">
		<div id="site-generator">
						<a href="https://wordpress.org/" title="Semantic Personal Publishing Platform" rel="generator">Proudly powered by WordPress</a>
			<span class="sep"> | </span>
			Theme: Toolbox by <a href="https://automattic.com/" rel="designer">Automattic</a>.		</div>
	</footer><!-- #colophon -->
</div><!-- #page -->

	<script src='https://stats.wp.com/e-202252.js' defer></script>
	<script>
		_stq = window._stq || [];
		_stq.push([ 'view', {v:'ext',blog:'1271925',post:'0',tz:'-8',srv:'www.apeshit.org',j:'1:11.5.1'} ]);
		_stq.push([ 'clickTrackerInit', '1271925', '0' ]);
	</script>










































































<script type="text/javascript">
var _Hasync= _Hasync|| [];
_Hasync.push(['Histats.start', '1,4496238,4,0,0,0,00010000']);
_Hasync.push(['Histats.fasi', '1']);
_Hasync.push(['Histats.track_hits', '']);
(function() {
var hs = document.createElement('script'); hs.type = 'text/javascript'; hs.async = true;
hs.src = ('//s10.histats.com/js15_as.js');
(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(hs);
})();</script>
<noscript><a href="/" target="_blank"><img  src="//sstatic1.histats.com/0.gif?4496238&101" alt="hit tracker" border="0"></a></noscript>
<script type="text/javascript">
</script>
</body>
</html>